Track volume relative to session box but not including folded tracks

106 viewsCSS Questions
0

Hi,

I have a midi controller with 8 faders. I want to be able to use those faders to adjust the track volumes for 8 tracks in a session box. I use grouped tracks in Ableton nearly all the time, not to mention drum racks. When I set up a script for track volume that is relative to the session box (which is what I want) I don’t see how I can tell the script to not include folded tracks. So if my first group has four tracks, my first five faders are controlling the volume of the group and then then four internal tracks. But I don’t want to control the volume of the four internal tracks. Just the group. I want to be able to do this for 8 groups.

When I am performing, I have my project set up in batches of 8 groups. I want to use the 8 faders to be able to quickly and easily bring the volume for the 8 groups in the session box, then be able to navigate to the next batch of 8 groups and do the same without touching the tracks that are in each group.

How can I set this up in Control Surface Studio?

admin Changed status to publish May 22, 2024
Attached Files:
0

” the key is making sure group/folded tracks are not expanded. When this is the case, the track volumes (mapped yo my faders) only control the group track volumes. It works as a move the session box as well. Then if I want to adjust the folded tracks volumes, I just have to expand the group and the faders work for the folder track volumes.”

How does this works when more than one folder track is openend? What is the behavior of the session box then and on wich way are the faders located to the ()group)tracks

karmashammer Posted new comment May 28, 2024
Attached Files:

It works as you would expect. In my script, I have the session box to include 8 tracks. So my eight faders will map to track 1 – 8. If say the second track is a group and it is expanded, fader one will control track one, fader two will control the group track, fader three will control the first track within the group and so on.

So it just goes left to right for 8 tracks. If I have two groups unfolded, they become part of those 1-8.

Sorry, it is hard to explain. Basically, keeping the groups closed means the tracks within the group will not be controlled by the fader. But when you unfold a group, then the tracks within can be controlled. But when you close the group again, it goes back to the original option.

0

Karmashammer!

You are a legend, thank you very much for the tip, its working!
I’m using it on a X-touch Compact, really a must have feature on it.
Coding to me is like a nuclear reactor for renaissance people, you should have seen me figuring out how to edit a json file.
I woul liek to understand why “true” made it work. Can you explaine it to me?

Cheers,
Pete.

admin Changed status to publish May 22, 2024
Attached Files:
0

Just an update. I have found a way to do what I want. I created my script and set each track volume control to not be relative to session box and also set to Include folded tracks to no.
Then I exported the scrip json file. In the json file I replaced the track_relative_to_session”:false with track_relative_to_session”:true. I saved the file and imported it as a new script.

That works how I wanted it to work. The key is making sure group/folded tracks are not expanded. When this is the case, the track volumes (mapped yo my faders) only control the group track volumes. It works as a move the session box as well. Then if I want to adjust the folded tracks volumes, I just have to expand the group and the faders work for the folder track volumes.

admin Changed status to publish May 22, 2024
Attached Files: