Problem with MFT Template?

64 viewsCSS Bugs
0

I’m having a problem configuring Knob 13 Button press on my midi fighter twister. No matter what I do, it seems to act like Knob 1’s button press. Probably its something I did wrong but perhaps its a bug in the underlying template?

Attached is my json.

Thx!

admin Changed status to publish May 22, 2024
Attached Files:
0

Thx! It seems like it’s OK – it’s knob 13 thats acting weird. It sends a msg on ch 1 of value 12, which I think is right if knob 1 is 0, The rest of the knobs seem ok too.

The problem is on the ableton side where button 13 is going to Track 1 instead of 13, so perhaps something there is overriding the click of 13?

Maybe I did some custom mapping via midi learn thats overriding the MFT map. I’ve been cloning the same project over and over so perhaps I’m just perpetuating this.

Bingo – that seems to be it. Not sure what I did because I’m not super handy in Ableton but when I create a new blank project with 16 tracks, each track seems to mute and control volume as expected. So the problem was my doing.

Thx! I think now I need to figure out what to do with Push Twists – perhaps send that track to a looper bus.

Anyway, Thx!!

admin Changed status to publish May 22, 2024
Attached Files:
0

Hey Bill,
Have you checked the actual midi data which they are sending (open the midi monitor menu at the top of CSS and press each of your buttons). Ensure that button 16 is sending the data set in the controller template midi channel, type, value. And the same for button 1.

In the script which you attached it looks like button 1 is controlling track 1 mute and button 16 is controlling track 16 mute. So It sounds like it could be the above.

admin Changed status to publish May 22, 2024
Attached Files: