[SOLVED] Reactions: “Track – set mute” doesn’t work

43 viewsCSS Questions
0

Live 11.2.11

It’s about this action:

“Track – set mute”

aka

“self.song().tracks[foo].mute = True”

This action has no effect on Ableton Live. However, if I press the button myself in Live, then the value of “self.song().tracks[foo].mute” does change.

admin Changed status to publish May 22, 2024
0

Thank you for your reply John. So I had to look at the “Reaction” again and realized that I was at fault. I simply hadn’t noticed that I have to end the second block with a “return” so that the “mute” doesn’t immediately reset in the 3rd block 😐 Sorry, you can close the topic…

The value ‘True’ probably came from the ‘custom mode’ that was switched on for a short time – but had no relevance here, since I had also tested this version – but unfortunately still with my own built-in error.

Sorry, you can close the topic…

admin Changed status to publish May 22, 2024
0

Hi,

From your screenshot, have you selected an option for the true/false parameter?
I know it is showing as ‘True’ in the code which you have circled but as you have it set to ‘GUI’ mode and not ‘custom’, you will need to ensure that you have selected an option for this.

admin Changed status to publish May 22, 2024
Attached Files: